Welcome to InfinitiScene.com - Home for Infiniti QX and Q enthusiasts!
You are currently viewing our forum as a guest, which gives you limited access to the forums. Why not register on our forums and gain the extra benefits that our regular members enjoy?

  • Enthusiast Owned and Operated!
  • Registraion is free.
  • You will be able to post, message, and interact with other members.
  • Our forum is full of friendly, knowledgeable members and staff.
  • Plenty of money saving opportunities from write-ups to maintenance help.
  • Create a garage and show off your ride and specs.
  • Opportunity for ad-free viewing.
  • Plus much more!

Registration is fast, free, and easy, so stop being just a guest and become one of our newly registered members today!

Tire pressure indicator light

Discussion in 'FX (03-08) - Wheels & Suspension' started by CycoDK, Dec 11, 2007.

  1. CycoDK

    CycoDK Member

    52
    0
    Qatar
    I have recently changed my rims to 22"s and my tire pressure indicator light stays on and does not go off and my pressure indicator on my monitor don't work too:frown:..is it normal when you change the rims??Did it happen to any of you guys??:confused:

    thx..
     

     *Registered members do not see this ad, register today!

  2. Deecarp

    Deecarp Premium Member Premium

    1,479
    12
    Bay Area
    QX60 AWD
    Darryl
    Did they place your factory TPS on your new rims, if so and they are not working then you might want to have the dealer take a look at it. unless one our resident guru's know of away to re-establish the readings. I would think Viet, Doc, Dave or Jeff may know the correct response to that... hopefully they can chime in on that.
     
  3. fxlr8

    fxlr8 Staff Administrator

    17,932
    762
    California
    None
    Garages:
    1
    If the tpm sensors are in the new rims and you are having this problem most likely they are not registering, you will have to take your car to a dealer and have them register the sensors.
     
  4. Psiclne

    Psiclne Guest

    Are the sensors the same ones that were on the Stock rims? If you just moved them from the stocks to the aftermarket there should (technically) be no issues. But if they are a new set of sensors then you have to take them in to get them reprogrammed. My Infiniti Dealer gave me the run around about they wont do them on the aftermarket wheels - so I took it to a Nissan Dealer and they took care of me.
     
  5. Dr.2K

    Dr.2K iS Doctor on Duty iS VIP

    11,683
    9
    Santa Clarita, CA
    2005 FX45
    Garages:
    1
    I concur with Jeff and Will.
     
  6. OP
    OP
    CycoDK

    CycoDK Member

    52
    0
    Qatar
    Thx guys..Ill check with the dealer in few days..it would'nt be a problem if I drive with it for few days right??
     
  7. Psiclne

    Psiclne Guest

    Nah - I was driving like that for 2 months or so. The stupid light on the dash stays on and the TPMS screen will beep at ya cuz it thinks theres a flat......
     
  8. No problems, i drove for 8 months when I put 19's on my Z and didnt bother changing the factory sensors, then i got the FX. Anyway, the light went off after a little while anyway.